Bug with new Venus version

Moderator: tr1p1ea

Post Reply
User avatar
kv83
Maxcoderz Staff
Posts: 2735
Joined: Wed 15 Dec, 2004 7:26 pm
Location: The Hague, Netherlands
Contact:

Bug with new Venus version

Post by kv83 »

Hey tr1p,

I was testing PindurTI, when I ran into a bug which propably is a cause of the new version of Venus. I did the following:

The ram is cleared.
I copied the venus.83g to PindurTI.
I run prgm -> A. (Don't know why though)
(Note that I don't delete anything)
I copied desolate.83p to PindurTI.
I run desolate.83p. It starts as it should. The old version of Venus took more space, and so you would got an memory error. But the new version is smaller.
Everything works. But after you start the game, and get to the last screen of text it hangs up.

I guess it's something related to the memory issue. :) Hope you can fix it.

(I didn't had time to see if it is the same on real calc, but I guess PindurTI works in this state almost as good as a normal TI-83)
Image
User avatar
kv83
Maxcoderz Staff
Posts: 2735
Joined: Wed 15 Dec, 2004 7:26 pm
Location: The Hague, Netherlands
Contact:

Post by kv83 »

*bump* you already looked into it? :|
Image
User avatar
tr1p1ea
Maxcoderz Staff
Posts: 4132
Joined: Thu 16 Dec, 2004 10:06 pm
Location: I cant seem to get out of this cryogenic chamber!
Contact:

Post by tr1p1ea »

I am unable to test on a real calc either :(.
"My world is Black & White. But if I blink fast enough, I see it in Grayscale."
Image
Image
User avatar
blueskies
Calc Wizard
Posts: 553
Joined: Tue 25 Apr, 2006 2:24 pm

tested....

Post by blueskies »

This seems to be a problems with only PindurTI. I checked on my 83 with venus 2.4 and the version of Desolate I have (readme dated 14/08/2004) and it works just fine. Even when run from prgmA it works.
CoBB
MCF Legend
Posts: 1601
Joined: Mon 20 Dec, 2004 8:45 am
Location: Budapest, Absurdistan
Contact:

Post by CoBB »

I don't understand the problem. Where does it hang? I can get into the game no matter how I do it (prgmA or program menu, whatever interrupt speed).
User avatar
kv83
Maxcoderz Staff
Posts: 2735
Joined: Wed 15 Dec, 2004 7:26 pm
Location: The Hague, Netherlands
Contact:

Post by kv83 »

It does hang after you start the game and get to the text. It won't go any further after the last text box.
Image
CoBB
MCF Legend
Posts: 1601
Joined: Mon 20 Dec, 2004 8:45 am
Location: Budapest, Absurdistan
Contact:

Post by CoBB »

Which one do you mean? What does it say? Did you try to press ESC?
User avatar
Madskillz
Calc Wizard
Posts: 745
Joined: Fri 17 Dec, 2004 10:22 pm
Location: Wandering around in the Jungle...
Contact:

Post by Madskillz »

your talking about the intro text correct? On the last of the intro text it freezes?

offtopic: Kv...nice avatar, I thought it said kv83 too!
The Revolution is here...
User avatar
tr1p1ea
Maxcoderz Staff
Posts: 4132
Joined: Thu 16 Dec, 2004 10:06 pm
Location: I cant seem to get out of this cryogenic chamber!
Contact:

Post by tr1p1ea »

I have test Desolate in PinurTI and it seems to work fine. You do realise that you have to press Mode (which is ESC i think) to close the intro text?
"My world is Black & White. But if I blink fast enough, I see it in Grayscale."
Image
Image
CoBB
MCF Legend
Posts: 1601
Joined: Mon 20 Dec, 2004 8:45 am
Location: Budapest, Absurdistan
Contact:

Post by CoBB »

Actually, there is a problem, but it isn't exclusive to PTI. Desolate crashes nastily on ROM 1.10 when you want to start a game from the menu.
User avatar
tr1p1ea
Maxcoderz Staff
Posts: 4132
Joined: Thu 16 Dec, 2004 10:06 pm
Location: I cant seem to get out of this cryogenic chamber!
Contact:

Post by tr1p1ea »

... Interesting, i have never had anyone report this before. I will have to check it out.

*dusts off Desolate code*
"My world is Black & White. But if I blink fast enough, I see it in Grayscale."
Image
Image
User avatar
DJ_O
Calc King
Posts: 2312
Joined: Mon 20 Dec, 2004 6:47 pm
Location: Quebec (Canada)
Contact:

Post by DJ_O »

I guess the ROM 1.10 is the newer TI-83s (2000)?
lloydkirk1989
Calc Wizard
Posts: 680
Joined: Wed 22 Dec, 2004 5:37 am
Location: West Palm Beach,FL
Contact:

Post by lloydkirk1989 »

Hmm...i didn't have that problem with 1.10. Desolate did crash when I ran it in VTI with rom 1.08.
User avatar
tr1p1ea
Maxcoderz Staff
Posts: 4132
Joined: Thu 16 Dec, 2004 10:06 pm
Location: I cant seem to get out of this cryogenic chamber!
Contact:

Post by tr1p1ea »

Was this the final version? I will have to look over the code ... strange that noone has ever reported this until now. Are these rom version rare?
"My world is Black & White. But if I blink fast enough, I see it in Grayscale."
Image
Image
lloydkirk1989
Calc Wizard
Posts: 680
Joined: Wed 22 Dec, 2004 5:37 am
Location: West Palm Beach,FL
Contact:

Post by lloydkirk1989 »

Yes, 1.10 was the final version for the 83.
Are these rom version rare?
Umm...yes. 83 roms are increasingly hard to come by.
Post Reply