App problems

One suite to code them all. An complete IDE and assembler for all your z80 projects!

Moderators: benryves, kv83

Post Reply
King Harold
Calc King
Posts: 1513
Joined: Sat 05 Aug, 2006 7:22 am

App problems

Post by King Harold »

The old App problem keeps haunting me (and others aswell I'd bet)
It still has something to do with invalid appheaders.

I thought I solved it (I added the old-style header with all the .db's after the .block 128)
But no. It's a workaround, and a bad one, because you'll end up with a double header, and you even have to put a jp around it, sounds silly no?
'Course it does, but if I don't do silly things I wouldn't be me anymore.
Well the problem is that it is (for me atleast) impossible to get my 84+ to accept the application. (singing by hand, re-downloading the key file, nothing helps)
This isn't too bad really, most apps will just work, but what if you want to use a Libraryhook? The one for which you have to put something at $4087?
thinking.. "2 headers.. 256 bytes.. + a jp.. another 3 bytes.. Hey! You'd be at $4103 allready!"
$4103 that's right, so I can't put anything at $4087 anymore without invalidating the app.. (yes I tried to.. it failed)


So, now comes the real question: What do I do?
Last edited by King Harold on Fri 17 Nov, 2006 4:45 pm, edited 1 time in total.
User avatar
benryves
Maxcoderz Staff
Posts: 3075
Joined: Thu 16 Dec, 2004 10:06 pm
Location: Croydon, England
Contact:

Post by benryves »

I'm not an application expert, sorry, so I cobbled together app support from what I could understand from the documents. I wrote a few "Hello World" apps, to test, some calling functions on a second page to check it all worked - and the apps ran fine in PindurTI as well as on hardware (sent via TiLP).

I'll write a few demos that I can verify work on my calculator and upload them (you'll have to wait until Monday I'm afraid) if you haven't resolved the issue by then.

I don't (and won't) use TI Connect, as it causes too many problems for me. Have you tried TiLP, or some other 3rd-party linking program?

Brass works more reliably as a multipage assembler, so it could be worth just creating a multipage program, exporting as a raw binary (with the header done manually), and using another app signer.
King Harold
Calc King
Posts: 1513
Joined: Sat 05 Aug, 2006 7:22 am

Post by King Harold »

I'll try anything that works, but it's the calculator who does the rejecting..
I'll also try other app signers but I doubt Wappsign would sign apps faulty (afterall, TI made it, and they know how they should sign apps) but you never know.
User avatar
Jim e
Calc King
Posts: 2457
Joined: Sun 26 Dec, 2004 5:27 am
Location: SXIOPO = Infinite lives for both players
Contact:

Post by Jim e »

You can't get your 84 to accept your app? Are using the USB link? TI connect will not send an app to an 84 over the usb that is less than 341 bytes(thats including the sig).

For small apps, try using that block statement after all your code. If your app is big enough you don't need it.

This is assuming this is your problem though.
Image
King Harold
Calc King
Posts: 1513
Joined: Sat 05 Aug, 2006 7:22 am

Post by King Harold »

It was 741 bytes but this seemed to work anyway (although I had to use .fill)
Which is really strange since the calculator rejected it after it was send (claiming that it was invalidly signed)

but all evidence seems to point to the size thing..

thank you very much Jim E, this problem has been driving me near-crazy for months :P
User avatar
Jim e
Calc King
Posts: 2457
Joined: Sun 26 Dec, 2004 5:27 am
Location: SXIOPO = Infinite lives for both players
Contact:

Post by Jim e »

King Harold wrote:It was 741 bytes but this seemed to work anyway (although I had to use .fill)
Is that the 8xk size or the actually binary size? Basically 341 bytes - 128 byte header - 96 byte = 117 bytes of code or data.
Image
King Harold
Calc King
Posts: 1513
Joined: Sat 05 Aug, 2006 7:22 am

Post by King Harold »

the 8xk size, I thought you meant the 8xk size..
User avatar
Jim e
Calc King
Posts: 2457
Joined: Sun 26 Dec, 2004 5:27 am
Location: SXIOPO = Infinite lives for both players
Contact:

Post by Jim e »

yea that would be under then.


I know this isn't our bug however it might be a good idea to compensate for this or warn for it. I think I should stick a warning in wabbitsign about it. It could really mess up those people trying to start programming apps and failing when they couldn't get hello world to work.
Image
King Harold
Calc King
Posts: 1513
Joined: Sat 05 Aug, 2006 7:22 am

Post by King Harold »

Yes a warning would be a good idea..
Or even auto-fill if it's too small?

Code: Select all

.fill 500-($ - main) , $FF
at the end also works fine
Post Reply